Currently, there are 0 users and 1 guest visiting this topic.
Author
Topic
#62359

Hi, I have been running WP for a long time, but just installed bbPress and the bbPress Attachments plugin.

In bbPress I can post new posts to the forums, but am running into errors each time I attach files (either PDF or JPG, and also tried DOC just for fun). The new post always contains the following error:

<my post test text here>

UPLOAD ERRORS:
slider-4.jpg: File not uploaded.

I checked the Errors log in the postmeta table and this is the error there:

a:3:{s:4:”code”;s:10:”php_upload”;s:4:”file”;s:25:”slider-4.jpg”;s:7:”message”;s:18:”File not uploaded.”;}

Now, I wonder if this is related to the problems I am having in the Media Manager. When I use the Media Manager to upload files, I intermittently get failed uploads! Which is extremely weird on its own. In reading through these support forums, I see that the Media Manager is used as part of the Attachments plugin, so I am wondering if the problems are connected. In the Media Manager, one time I will get the error (which I have thoroughly researched and supposedly corrected):

slider-4.jpg
Missing a temporary folder.

And then a second later I try again and the file uploads just fine! I have been on support with my web host and they say they’ve corrected all file/folder permissions and that everything works on their end when they try.

So, can you tell what is going on from the error code I posted above? I also removed all Caching plugins, but it doesn’t seem to have helped.

Thanks for your support.

Topic Information
General Question
7.0
5.2.3
3.2
https://www.parentresourcectr.com/forums/topic/marketing/#post-2564
Viewing 8 replies - 1 through 8 (of 8 total)
Author
Replies
  • #62360

    Hi,

    Both errors are coming from the server and core PHP code that handles uploads. You should consult your server hosting support so they can check why upload fails, because files don’t reach WordPress, and my plugin actually uses WordPress upload handler.

    Milan

    Dev4Press - Premium plugins for WordPress.

    1 user thanked author for this post.
  • #62361

    Great, I really appreciate the quick response and target to go to so I can get this fixed. Thank you!

  • #62362

    I was about to get online with my host support people, when I decided to try adding the bbPress forums and this Attachment addon into another WP site I run (from the same Host).

    I got a similar error when installing the GD bbPress Attachment plugin, but this time I noticed an error message on the failed plugin install which referenced a temp folder of /tmp/…… . I don’t have that folder in my directory structure. I have /wp-content/temp, but not /tmp.

    So I added that folder, set the permissions as 755, and tried installing the plugin, and it worked! So I went back to my original website and added the /tmp folder. At first I had sporadic results attaching files in the forums, and I thought it might be related to file sizes. But, I just kept trying different file sizes, and now (maybe the server had to catch up on something) I seem to be able to attach everything to the forums posts!!

    I don’t think my problem is solved, and I still need to contact the host tech support, but at least I am able to complete my task of attaching files to forums posts today!

  • #62363

    I have another question:

    Through trial and error, I’ve found that if an upload fails, I can usually “edit” the post and then do the upload again through the Edit Post page, and so far the upload has gone through each time on the second try.

    Now, though, the post gives the info about the attachment (with the [delete] and [detach]) links, but also below that is the original upload error warning message… even though right above it is the good link to the attachment!!

    How can I get rid of the Error message so it doesn’t show up on a post which has a successfully attached file? I am able to modify the tables via phpMySQL and can do it there if need be.

    Thanks again!

  • #62364

    All this points to huge issues with the server configuration. TMP folder for PHP should not be in WordPress folder, it should be somewhere on system level, and it has to be configured global. Also, PHP configuration has options related to upload (POST size, file size, timeouts…) that all has to be configured. Your host has to make significant updates to the configuration, and after all that has been updated, you can use plugin. If the errors continue after that we can see what they are caused by, so make sure to have debug into log file enabled to s that PHP can log all errors.

    Dev4Press - Premium plugins for WordPress.

  • #62382

    Ok, thanks for all the support. I contacted my hosting support and copied over all your good explanations, and I *think* they fixed it. Got back the explanation “I’ve specified temp folder within php.ini editor. This should resolve the issue.” Don’t know why this would ever have NOT been set, but hopefully it’s good now.

    Still wondering if/where I can edit existing posts so I can remove the

    UPLOAD ERRORS:
    Class Flyer 4.pdf: File not uploaded.

    which is embedded in some of my forums posts. It is coming from somewhere, but not in my post text itself. I can access the SQL data, just not sure which tables would have that info stored in them.

    Thanks again!

  • #62383

    Ok, never mind. I am just too curious, so I dug around and found the entries in the wp_xxx_postmeta table. Got them deleted and now everything looks sweet.

    Thanks for creating and supporting this very useful plugin!!

    Chris

  • #62384

    Excellent. I am closing this topic now.

    Dev4Press - Premium plugins for WordPress.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Attachments not uploading – problems in bbPress Attachments AND WP Media Manager’ is closed to new replies.