Currently, there are 0 users and 1 guest visiting this topic.
Author
Topic
#63672

I have disabled my ‘bulk’ emailing notifications from my forum whilst I resolve my other ticket
But a few ‘admin’ emails are still going through – today there have only been 4.
These for appear in the gd mail queue log file – 2 entries for each mail – one with status “WP Mail to queue” and the other with “Queue Sent ok”. I assume this means the email was intercepted by gd mail queue as it was sent by wpmail and the the queue has sent it ok – and yes i did receive the emails.

My problem is that although is gd mail queue is configured to use ‘custom smtp server’ they are not appearing in my smtp server log files.
To me that means they have not been sent to my custom smtp server but have been sent via default WP email using my hosting server email. Am I correct? This is not a problem to me for just 4 emails a day but later when i am regularly send blocks of 140 odd emails they must all go via my smtp server – for obvious reasons.
If so how do I force my mail to be sent to my smtp server and how do I get that fact reported in the gd mail queue log files – perhaps a status of ‘queue to smtp server’ or something as distinct from just ‘queue sent ok’ as ‘queue sent ok doesn’t tell me how the email was sent – ie by my host or by my smtp server?

the only relevant gd amil queue settings I can see are
1) ‘PHPMailer’ which is set to default “PHP Mail Function’, I find the note about setting to SMTP server confusing and if i set it to that id doesn’t seem to make any difference anyway.
2)’Custom SMTP Server’ is correctly configured as I have had emails go through to it as recorded in their historical log

So am i missing something in the configuration to use custom smtp server?

also from the other ticket advice, I have added the commands to my wpconfig.php file to activate logging but there is nothing in the file as the file is not in the directory with wpconfig.php. these are the lines in wpconfig.sys
define(‘WP_DEBUG’, true);
define( ‘WP_DEBUG_LOG’, true );
define( ‘WP_DEBUG_DISPLAY’, false );

Viewing 5 replies - 1 through 5 (of 5 total)
Author
Replies
  • #63673

    Hi,

    If your PHPMailer option is set to ‘PHP Mail Function’ it means that it doesn’t use Custom SMTP server. If you switch PHPMailer to ‘Custom SMTP Server’ only then it will use settings from the Custom SMTP Server page. I will include some extra explanation about this to avoid future confusion with this option. Also, I will add one more feature currently present in Pro edition and that is
    plugin dashboard information about currently active sending method, so you can always see what is configured without going through settings.

    Regards,
    Milan

    Dev4Press - Premium plugins for WordPress.

  • #63674

    Hi Milan

    That would be great

    I’ll change the setting and see what happens with next few admin emails

    thanks for the very prompt response

    Richard

  • #63675

    No problem, glad I could help.

    Dev4Press - Premium plugins for WordPress.

  • #63676

    well I just got another admin email and it went via smtp after i changed the setting – as you expected it would ๐Ÿ™‚

    thanks again

  • #63677

    ok to close this ticket

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘More queue issue’ is closed to new replies.