Currently, there are 0 users and 1 guest visiting this topic.
Author
Topic
#12728

Hello,
I just uploaded the plugin to my bbPress site (which is a sub-site of another WordPress site) but when I click on the Settings tab it gives me this message: “You do not have sufficient permissions to access this page.”

I am not sure what to do. Can you help?

Topic Information
Viewing 6 replies - 1 through 6 (of 6 total)
Author
Replies
  • #12731

    Only admins get to see this page, plugin uses ‘edit_posts’ capability to show it.

    Milan

    Dev4Press - Premium plugins for WordPress.

  • #13648

    Zemljace imam isti problem samo sto sam ja admin sajta ako si na to mislio ali nisam admin web servera na kome imam hosting paket.Da li treba da hvatam za gusu admina tj onog sto mi prodaje paket ili postoji neki drugi nacin da se to zaobidje.Ionako mi daju memory_limit po domenu 32mb.Hvala ๐Ÿ™‚

  • #13769

    This is WordPress, not server related. But, as I said, plugin uses edit_posts cap for this, if you see the error message, than it is something on your end wrong.

    Dev4Press - Premium plugins for WordPress.

  • #13770

    dobio sam odgovor da su neke funkcije i pluginovi laki za “upad” (iskljucen mi je shell_exec) odavno i par dana posto sam instalirao vas plugin on je radio kako treba nije imalo potrebe da ga diram i odjednom da vidim info kaze kao sto je momak napisao.Verovatno je admin servera zabranio to a sto se tice njihovog odgovora u vezi plugina kasnije sam shvatio da je na to mislio.Indijanci su pravi ๐Ÿ˜‰ samo sam hteo da podelim iskustvo vise i kazem da admin servera moze nekako da zabrani to

  • #17358

    Hi.
    We are experiencing similar strange problems using this plugin.

    The issue is basically this:
    —————————–
    The ‘GD Press Tools’ plugin is not fully activated when we select ‘activate’. There is no GD Press Tools on the left Admin toolbar.
    We are getting ‘You do not have sufficient permissions to access this page.’ when trying to access ‘http://${domain}/wp-admin/admin.php?page=gd-press-tools-settings’
    —————————–

    Steps that we have taken to resolve but have been unsuccessful are:
    —————————–
    * Turned up debugging and tried to figure out which log messages were relevant when we activated the plugin and when we went to the settings page. We followed through on some of them and determined that as far as we could tell, none of these messages were causing the issue that we are seeing.
    * Deleted the plugin and re-installed (both with the GUI and from the command line)
    * Compared the directory on a known, working site with the site that wasn’t working (using diff -rq /path/knownGood /path/bad)
    * Compared the differences between two mysqldumps
    * On the ‘broken’ server we did a dump before activating the plugin and after
    * On the ‘good’ server we did the same
    * We diffed (colordiff -rupN before.sql after.sql) in two separate windows and compared the changes in each database
    * We cloned the ‘broken’ site to a new server
    * Tried disabling all other plugins
    * Tried deleting all other plugins
    * Tried setting permissions wide open (chmod -R 777 … ;; chown -R …)
    * Tried Re-installing the latest WordPress core from the “Updates” screen in the GUI
    * We noticed that there were some non-default WP roles so we installed the “User Role Editor” and deleted the non-default ones… We then noticed non-default ‘capabilities’ so we tried updating roles with known good roles:
    * START TRANSACTION; UPDATE mytrccmb.wp253_options SET option_value = (SELECT option_value FROM erbzkske.wp_options WHERE option_name = ‘wp_user_roles’) WHERE option_name = ‘wp253_user_roles’; COMMIT;
    * We tried creating a new site to work with and test with (same wp version and gd press tools version):
    * We installed/activated gd press tools plugin (this worked, as expected)
    * We restored a backup of the ‘broken’ database to this app… stopped working, same results
    * We updated the necessary db settings in wp-config.php and modified the DB settings (home and site_url or something like that) in the wp_options table as needed

    These are only some of the things we’ve tried to get the plugin working, but have run out of options and things to try. Any suggestions on what else to do?

    We don’t believe it to be a file-system permissions issue.

    Any help from a developer or someone with intimate knowledge to this plugin would be greatly appreciated.

    Jason Hand
    Director of Technical Support
    Standing Cloud
    www.standingcloud.com

  • #17359

    Plugin sets up several user capabilities used to display menus. Plugin adds those caps to administrator user roles by default. That is all is needed. And message about permissions points out for user not to have the caps, and that can happen if you are using non-administrator role.

    Milan

    Dev4Press - Premium plugins for WordPress.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Settings page says "You do not have sufficient permissions to access this page"’ is closed to new replies.